Jump to content

New Stake Version Feedback


Featured Comment



Another bug which has been spotted is a result of the introduction of the new fiat currencies. To be exact it is the Korean Won (krw). With a screenshot reference I have included above 1.17USD is being converted 137,217krw which has increased the balance by a 100X.


Upon checking the is no loss which actually occurs resulting from that safe except individual bets become very small and it makes the purchase of free spins from certain providers extremely affordable. Please refer to the screen shot taken of Book Of Shadows and note the price is now 100X cheaper than the original price.


The korean won (krw) bug is affecting slots mainly. A short list of the affected slot providers which are affected are below (mainly consist of slot providers which has feature purchases), which are:-

a. Hacksaw Gaming                                         

b. No Limit

c. Play & Go

d. Blueprint

e. Booongo

f. Elk Studios

g. Evoplay

h. GameArt

i. Golden Hero & Gamomat (Slots could not be opened - fail to open) ... I suggest to run through all slots

This bug does not affect the Stake Originals. 

Currency Not Supported - Belatra -1.JPG


As for certain sites (example for providers like Pragmatic) they disallow entering their site. This bug is not in the Stake (beta) but is in the Stake 3.0.

Edited by StromShadow
Link to comment
Share on other sites

Looks good. Like the hide zero balances feature. I'm personally not a fan of site animations, but feels smooth. 

On giveaways could we get a bar showing progress for each ticket?

On mines auto, can we get a multiplier view when selecting diamonds so multi can be seen on site. 

Link to comment
Share on other sites

I suggest,  the name of game on My Bets panel can be replace with Bets ID so we don't need to click for just to see the number of Bets ID, but for the game icon is still there, for knowing the type of game.


Link to comment
Share on other sites

1 hour ago, EuroCanuck said:

i cant even login... allowed popups..waited like someone else suggested, nothing..

Use https://beta.stake.com . 

You will be greeted with a similar login screen fairly similar to your current Stake Login screen (for easy reference a screenshot is enclosed below for you to compare).


Log in as usual and you should be in.

Link to comment
Share on other sites

14 hours ago, Onessone said:

LIMBO game : 1.01 terget is not working






You are right, you have to set the Target Multiplier to 1.0103 to enable the button

Edited by Xylber
Link to comment
Share on other sites

i still cant login on the beta, i put username/passowrd, do the captcha, it says use the google/facebook autherization,  and then when i click the Google button the popup just flashes quickly and disappears ...iv turned off popup blocker, adblocker...tried 3 different browsers, all same result 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...